Tag: php8

PHP7

Update PHP7 shared hosting en reseller platform

PHP 7.2.x wordt niet meer ondersteund en vervangen voor PHP 7.4 als default PHP versie op de meeste servers. Oudere versies zijn alleen nog als optie beschikbaar. Update uw website en pas de PHP-versie welk u gebruikt aan!

PHP7 maakt nog steeds ontwikkelingen door en er is inmiddels ook een aankomende release van PHP8. Aangezien de meeste systemen zoals WordPress en Joomla er inmiddels al lang klaar voor zijn updaten we alle shared hosting en reseller-servers deze week naar PHP 7.4. Daarmee komt ondersteuning voor oudere versies te vervallen.

Voor websites die nog steeds gebruik maken van legacy code is er een oudere versie beschikbaar. Op de helpdeskpagina vindt u een handleiding hoe deze versie in te stellen.

Update uw website!

We benadrukken hierbij nogmaals dat het gebruiken van een courante PHP-versie zeer belangrijk is. Is uw website nog steeds gebaseerd op PHP versies kleiner dan 7.2.x dan moet u zéér binnenkort updaten. Controleer daarom of uw website werkt op PHP7+. Zoniet, dan zal deze binnenkort mogelijk niet meer werken omdat wij oudere versies zullen uitzetten en niet meer ondersteunen.

Het blijven gebruiken van (zeer oude) scripting (oude versies van WordPress, Joomla e.a.) is niet alleen een probleem voor u zelf maar kan ook een probleem worden voor andere klanten. Bijvoorbeeld wanneer er brute-force aanvallen op uw verouderde websites plaatsvinden of kwaadwillenden proberen in te breken op uw website. We kunnen dit dus niet (lang) meer toestaan.

Ondersteuning bij update

Hebt u ondersteuning nodig bij het updaten van de website software, dan kunt u contact met ons hierover opnemen via dit formulier. Support is op basis van best effort. Schakel ons dus tijdig in ingeval u een update van de software van uw website wilt laten uitvoeren om downtime te voorkomen.

PHP8 migratiepad

Wij ondersteunen maximaal drie PHP-versies op dit moment. Hoewel het technisch haalbaar is meer versies te ondersteunen zien wij hier het nut niet van in, integendeel. Oudere versies zijn kwetsbaar en worden door de makers van PHP niet meer ondersteund. Wanneer PHP8 voldoende rijp is om beschikbaar te stellen zullen wij deze ook als optie beschikbaar stellen op de servers en daarna geleidelijk alles onder PHP 7.4.x uitfaseren. Meer over PHP8 vindt u op onder andere Tweakers.